SCSIRAIDGURU’s World
Cisco Virtual Lab Simulations
SRG

SCSIraidGURU’s World

Route Summary in OSPF

Each of the routers has the loopbacks in OSPF and setup point to point.   IP OSPF Network point-to-point allows the Sh IP Route to list the addresses properly in their subnet.  Loopbacks  are /32 by default. 

interface Loopback0
 description Loopback
 ip address 192.168.32.1 255.255.255.224
 ip ospf network point-to-point
 ip ospf 1 area 1
!
interface Loopback1
 ip address 192.168.32.33 255.255.255.224
 ip ospf network point-to-point
 ip ospf 1 area 1
!
interface Loopback2
 ip address 192.168.32.65 255.255.255.224
 ip ospf network point-to-point
 ip ospf 1 area 1
!
interface Loopback3
 ip address 192.168.32.97 255.255.255.224
 ip ospf network point-to-point
 ip ospf 1 area 1
!
interface Loopback4
 ip address 192.168.32.129 255.255.255.224
 ip ospf network point-to-point
 ip ospf 1 area 1
!
interface Loopback5
 ip address 192.168.32.161 255.255.255.224
 ip ospf network point-to-point
 ip ospf 1 area 1
!
interface Loopback6
 ip address 192.168.32.193 255.255.255.224
 ip ospf network point-to-point
 ip ospf 1 area 1
!
interface Loopback7
 ip address 192.168.32.225 255.255.255.224
 ip ospf network point-to-point
 ip ospf 1 area 1
!

With OSPF, I can use default-information originate always for my default router for tftp.  My external route shows up as a Type-5 external links.

router ospf 1
 router-id 1.1.1.1
 redistribute static metric 15 subnets
 default-information originate always
ip route 0.0.0.0 0.0.0.0 172.16.1.1

 

	Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
0.0.0.0         1.1.1.1         213         0x80000001 0x001D91 1

The route summary commands in OSPF and not the same as RIP and EIGRP.  These commands are done on ABRs and ASBRs.  The border routers can only do them.   I did it for Area 0 and 1.  I did nothing in area 2.   Check the Sh IP Route after commands to see the difference.  iosv2 and iosv3 have the commands. 

router ospf 2
 router-id 2.2.2.2
 area 0 range 192.168.33.0 255.255.255.128
 area 0 range 192.168.33.128 255.255.255.128
 area 1 range 192.168.32.0 255.255.255.0

Route Summary Before

Route Summary After

Close Menu